Search found 1 match

by paulyg123
Sunday 22 Jan 2017, 20:12
Forum: Products - FSX, FSX:SE, Flight Sim World, Prepar3D
Topic: New York City X
Replies: 310
Views: 129902

Compatibility Question

I am new to P3D and just discovered your great work. I read many of the posts - didn't find exact answer, so be patient and answer this one question. I have P3D version 3.4. I just installed it last week. So when buying your products like New York City V2, if is says P3D Version 3 compatible, can I ...